Sega Nomad Lcd Mod Flicker

Discussion in 'Modding and Hacking - Consoles and Electronics' started by ramiq27, Sep 11, 2018.

  1. ramiq27

    ramiq27 Spirited Member

    Joined:
    Dec 11, 2015
    Messages:
    102
    Likes Received:
    41
    I have installed an LCD to my Nomad but I'm getting some slight flickering. I also feel the colors are not quite right.

    There are guides online on how to fix this by jumping some wires on the step down chip but they all have a different board than mine .

    Any idea what can be done to fix this?

    [​IMG]

    [​IMG]
    [​IMG]
     
  2. highfroman

    highfroman Newly Registered

    Joined:
    Oct 24, 2016
    Messages:
    2
    Likes Received:
    1
    i think i had this board before,flip the board over to the bottom and clean off the gunk, look for a test point labeled 5V, solder your power connection to this point

    the nomad runs off 5V and the screen your using is 12V but steps down to 5V to power the actual display. you need to feed the 5V into where the 5V is to power the screen. the screen flickers because its not getting enough power. your other option is to google each chip until you find the voltage regulator and get the pinout and feed 5V where the chip outputs 5V
     
    ramiq27 likes this.
  3. ramiq27

    ramiq27 Spirited Member

    Joined:
    Dec 11, 2015
    Messages:
    102
    Likes Received:
    41
    Thank you so much for this. I finally got around to working on it again and managed to fix it using your tips.

    I soldered a connection between pin 2 on the XL1509 chip (step down chip) to the 12V connection on the screens plug (where the red wire connects). It sort of solved the problem but eventually the flicker would show once in a while. I then noticed the screens wires were kind of thin and of poor quality and probably weren't good enough for a power connection. Once I replaced all of them the screen and picture tuned out great.
     
    somacast likes this.
  4. segasonicfan

    segasonicfan Robust Member

    Joined:
    Sep 23, 2011
    Messages:
    262
    Likes Received:
    40
    I have this same board, and also had to jumper wire along the outer right edge of the ribbon cable. The problem for me was the LED backlight connection.
     

Share This Page