PsNee: a stealth modchip for all PS1-models

Discussion in 'Modding and Hacking - Consoles and Electronics' started by TheFrietMan, Aug 28, 2015.

  1. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    Well, it all seemed a bit too good to be true :-/
    The A18 signal at about 11 seconds is only generated with original discs, not with backups, neiter of PAL nor NTSC region. I've included screenshots comparing the logic captures from various discs. I don't really know how to proceed from here, anybody's got any ideas? TriMesh?
     

    Attached Files:

  2. TriMesh

    TriMesh Site Supporter 2013-2017

    Joined:
    Jul 3, 2008
    Messages:
    2,372
    Likes Received:
    785
    OK, does the PAL backup actually boot? That looks like it's failing the validation early on and isn't even getting as far as the license check.
     
  3. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    First i would like to say thx for your great work.

    Found the answer on page two. Dividing internal clock by 8 must be deaktivated.

    Thx a lot
     
    Last edited: Oct 9, 2015
  4. Mord.Fustang

    Mord.Fustang Fiery Member

    Joined:
    Feb 17, 2013
    Messages:
    824
    Likes Received:
    186
    I couldn't get it working so far on ATTiny85. I got a generated PsNeeEnglishV2.cpp.hex file from Arduino IDE and used an external program + USB programmer to program it, using the fuses on page 2, but it didn't work in the PS1.

    Any chance you can simply upload your a Hex file yourself @TheFrietMan to try and eliminate a variable?
     
  5. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    I will now solder it using a socket. if it works fine i can give you my hex.
    But if compiling was fine without errors it should not be any different.
     
  6. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Used attiny85, compiled fine, flashed correctly.

    Board: PU-23

    But it does not work :(

    Is it right that only 5 wires are soldered? Pin 3,4,5,6,8 Right?

    On the pictures for wiring the v2 only these numbers are used, all other points have no numbers.

    Seems that V2 changed from pin 7 to 3 as at the beginning frietman wrote pin 3 not Connected, but on the pictures for v2 it is used. 1,2,7 are not connected regarding the pics.

    Iam a bist confused now, and dont know why it does not work... Any idea?
     
  7. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    There are some issues with PsNeeV2, I won't recommend installing it in your Playstation, I only posted it to show some progress, it was not tested on actual hardware.
    @TriMesh: I've tried spamming the SCPH-102 withe SCEx-codes, but it won't ever authenticate a NTSC disc, it never gives off the A18 pulse at about 11 secs like original and PAL backups do. Is there something else I need to watch for?
     
  8. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Okay so i will try V1 Then :)

    Is the wiring correctly? Should i use pin 3 or 7 then?

    The Numbers of the pictures are already translated or do i have to translate them using your mapping table?

    Thx
     
  9. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    I'd suggest waiting for V3 to come out, V1 has some issues with playing original discs, for backups it works fine.
     
  10. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
  11. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    Then dig up a wiring diagram for a normal modchip like MM3 and use that wiring diagram with the pin conversion table I posted :)
    I've included one I had locally for convenience.
     

    Attached Files:

    • 900x.jpg
      900x.jpg
      File size:
      67.2 KB
      Views:
      740
  12. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Okay, the one i found looks different... Now iam not sure which one of them is fitting psnee :D

    [​IMG]

    Pin 1 is different for example. Or does it not matter because both points give VCC?
     
  13. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    I can't see your image, but pin 1 indeed is Vcc, that can be tapped off various points on the PCB.
     
  14. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Great, Thx. I will try it out...

    Any estimated time when a working v3 should be ready?
     
  15. TriMesh

    TriMesh Site Supporter 2013-2017

    Joined:
    Jul 3, 2008
    Messages:
    2,372
    Likes Received:
    785
    Not that I can remember - I just had a look, and I don't have any SCPH-102s here to run tests on. I will try to get one and see what results I get.
     
  16. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    That will be when PAL SCPH-102 NTSC-support is added :)
     
  17. TheFrietMan

    TheFrietMan Active Member

    Joined:
    Aug 28, 2015
    Messages:
    30
    Likes Received:
    15
    Hmm, that would be awesome. In the meantime I'll continue testing and trying things, just drop me a message if something pops up in your head ;-)
     
  18. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Psnee v1 also does not work on my PAL PU-23 version :/

    It passes the first check (white background with Sony logo), then the black background with the play station logo appears and there it gets stuck :(

    I have also a PAL psone here SCPH-102 I think but did not try with it yet.

    Any idea how i could get it running on the older PU-23 board to pass the second check? :)

    Adjust any timings in arduino maybe?
     
  19. Mord.Fustang

    Mord.Fustang Fiery Member

    Joined:
    Feb 17, 2013
    Messages:
    824
    Likes Received:
    186
    Since I'm not the only one with issues I'll just wait until V3 comes out before trying it again. I'll create new wiring diagrams if needed as well.
     
  20. DioABD

    DioABD Member

    Joined:
    Oct 8, 2015
    Messages:
    9
    Likes Received:
    0
    Yes, it is not your wiring diagram, it was correct.

    Seems that the Code itself does not pass the second check on my hardware.
    If i had enough time i would try to optimize it for my hardware. (Made lot of arduino projects in the past and i like it)

    But for now:

    I ordernd 2 pics for 1€ each for a onechip to try if it will fix my issues.

    If a V3 comes i will give it another try of course :)
     

Share This Page