Help Weird :Psone PAL with RGB cable display image without color

Discussion in 'Modding and Hacking - Consoles and Electronics' started by gamer2000, Mar 3, 2018.

  1. the-force

    the-force Member

    Joined:
    Mar 7, 2016
    Messages:
    8
    Likes Received:
    0
    Which component do you think is the problem? I think the TV can't be the problem as it is the same with a Scart 2HDMI converter.
     
  2. TriMesh

    TriMesh Site Supporter 2013-2017

    Joined:
    Jul 3, 2008
    Messages:
    2,355
    Likes Received:
    778
    My guess is that nothing is actually faulty - it's just that the cable was designed based on the behavior of the older consoles. You could try removing R542 on the PSone, which would eliminate the latch on the protection circuit, and hence make it work like the old ones.
     
  3. the-force

    the-force Member

    Joined:
    Mar 7, 2016
    Messages:
    8
    Likes Received:
    0
    According to Robert from retrogamingcables they have tested the RGB cables with a PSone on a TV with Scart and no problem.
     
  4. TriMesh

    TriMesh Site Supporter 2013-2017

    Joined:
    Jul 3, 2008
    Messages:
    2,355
    Likes Received:
    778
    So the specific combination of TV and console they used worked. The combination of console and TV you have does not.

    I'm not really sure what the question you are asking here is, though. If you don't want to modify anything, then the surest course of action is to get an older PlayStation (SCPH-7502 or earlier) that doesn't have the latching over current protection on the video port 5V line. I don't think any of the components are individually defective - they just don't want to work together.
     

Share This Page