EverdriveGB issue

Discussion in 'Everdrive General' started by radiokid, May 10, 2016.

  1. radiokid

    radiokid Rising Member

    May 10, 2016
    Likes Received:
    I have a modded backlit/biverted Game Boy DMG-01. With green backlight (with resistor to limit voltage to the backlight as recommended by Handheld legends website). I haven't had any issues with regular games on this game boy.

    With the everdrive only a few games actually load properly. Example of some that work are Tetris, Super Mario Land, Duck Tales. Games I have tried that don't work, Adams Family, Duck Tales 2, Tetris 2, Mystic Quest, Super Mario Land 2, Warioland.

    When I say dont work, what I mean is that when I choose Load and Start (or Load, and then manually start), I get the usual Erase... then Write with however many dots, then the Game Boy resets, but the Nintendo logo is garbled, and then nothing... it just sits there.

    The games that work, same Erase... Write... then Game Boy resets, Nintendo logo comes on and game starts fine.

    I have tried the everdrive with different SD cards, Sandisk, Kingston of varying sizes from 2GB to 16GB, with no difference. I have also tried on my Super Game Boy, with the same issue. However, and here's the weird bit, I have tried the everdrive on both my Game Boy Color and Game Boy Advance. I do not get the same issues on these devices. In fact if I load a problem game on either the GBC or GBA, then take the everdrive and put it into the Game Boy DMG, then it starts fine. So the problem appears to be with either erasing or writing the ROM with the everdrive when it is in the Game Boy DMG.

    Couple of videos showing my issues, and also a picture of the cartridge iteself, the contacts look a little mucky, maybe I should give them a clean and see if that helps.

    Everdrive on Game Boy (I get the same issue if I remove the backlight and Bivert chip)

    Everdrive on Super Game Boy


Share This Page