Can this be fixed or is it dead?

Discussion in 'Turbo Everdrive' started by rayik24, Feb 19, 2016.

  1. rayik24

    rayik24 Active Member

    Joined:
    Nov 8, 2013
    Messages:
    36
    Likes Received:
    6
    Have enjoyed TEDv1. 1 for almost 4 years with no problems.

    Was using TED playing game. Walked across carpet to system to push reset button. As I touched TED static electricity shot out (saw white light). Black screen and TED loading light went on and stayed on.

    Now, whenever system is turned on TED loading light goes on and stays on. Eventually I will get a white screen. Removed microsd card and same result. (Tested microsd in pc and it is read okay) Turned on system holding buttons I and II and same thing happens.

    TED has mini usb installed. I also note the serial header pinout. Is there anything I can do to get this or working or is it dead? Thank you for helping
     
  2. wilykat

    wilykat Site Supporter 2013

    Joined:
    Mar 25, 2012
    Messages:
    991
    Likes Received:
    45
    Do you have regular Hucard game to test the console with? If the console works, then your TED is cooked. If it does not work, you may have a big problem.

    You might need to send your TED in for repair. You can go to http://krikzz.com/forum/ and look for Krikzz there.
     
  3. rayik24

    rayik24 Active Member

    Joined:
    Nov 8, 2013
    Messages:
    36
    Likes Received:
    6
    Console works with other Hu cards,. I've posted at Krikzz's forum. Thank you.
     
  4. rayik24

    rayik24 Active Member

    Joined:
    Nov 8, 2013
    Messages:
    36
    Likes Received:
    6
    Krikzz fixed TED 1.1 at no cost ( including return postage from Ukraine to US). My only cost ws sending to Krikzz
     

Share This Page