Borked DC Dev kit

Discussion in 'Sega Dreamcast Development and Research' started by MexicanGritzTaster, Feb 7, 2005.

  1. Hello everybody,

    I have just obtained a Dreamcast development tower, and it seems that information on this beast is a little hard to come by. Searching brought me to this site.

    Anyway, I have an issue, but I have no idea how serious it is. The Dev kit was actually a joint purchase between a buddy of mine and I. Last night, when we got it, we tried to get it working. Along the way, apparently a couple of roms needed flashing (Im short on details... it was late and I wasnt at the helm), I guess he had been using the R10.1 development software with a 5.13 or 5.14 box (I cant remember). Anyway, I remember the flashing software saying one of the roms had version 0.00 in it. When he tried to flash that one, it failed, so he tried again... and it succeeded, but I think it messed things up. Now if I am lucky, on a TV (I havent tried VGA), the sega logo comes up like before a game is about to launch, but its all white and staticy... then I just get a black screen. The PC software indicates that something is going on, but for the life of me, I just see nothing.

    - So... could this firmware flash be my problem?
    - If so, can I somehow flash it back? Where would I get the proper rom?
    - If the firmware ISNT the problem, what could be going on? Like I said, it is certainly computing, just the output seems screwed

    Your Friendly Mexican Gritz Taster
     
  2. VitAmen

    VitAmen Guest

    ...

    first of all determine the model...

    Check the sticker at the bottom...it has a serial number that reads like
    "Sxxx...."

    The xxx is the version....As for the proper rom,without knowing which model you have you do not know which sdk revision tou use...
     
  3. Talked to my buddy

    He says the sticker has "S514S", which I guess indicates version 5.14.
     
  4. VitAmen

    VitAmen Guest

    ...

    5.14 huh?

    Could you please take some photos along with its inards?It would be nice to have most of the devboxes documented...

    Anyway,i remember mindchild from this messageboard had some problems like this.I think he had a 5.16 box and used wrong firmware...
    From what i recall he was searching for SDK R6 cause that was right for 5.16,so i guess 5.14 is somewhere between R5-R6...

    Try contacting mindchild or RICKY,cause he has loads of SDK revs...
     
  5. :(

    Well, I got a hold of Dev software 10. I tried flashing the roms with the roms from that package (how much worse could it get), and the one that was originally v0.00, wont pass the tests, wont flash anymore, with anything. I am beginning to wonder if the rom situation was different on these older machines, and I really screwed up. I really with there was a means to get these back to "factory defaults".

    Where/How can I get a hold of those people?
     
  6. Calpis

    Calpis Champion of the Forum

    Joined:
    Mar 13, 2004
    Messages:
    5,906
    Likes Received:
    21
    Maybe you should replace the flashrom or try writing the flash with a programmer instead of doing it insystem.
     
  7. VitAmen

    VitAmen Guest

    ...

    Series 5 was the last generation of boxes.I guess if you find the right SDK version you might be able to restore it.But the situation with the boot rom is tricky.

    If you do not get to restore it with software the only solution is hardware.I think the boot rom is replaceable.Just find a reasonably skilled electrician to do the thing if you cannot.Find an identical rom,flash there the boot rom for the SDK with a rom writer and then put it in the box...
     
  8. LeGIt

    LeGIt I'm a cunt or so I'm told :P

    Joined:
    Mar 13, 2004
    Messages:
    3,439
    Likes Received:
    35
    SDK R10 isn't for anything older than 5.24 dummy ;) You may get away with R9 which is floating about, but chances are you may need an older revision SDK, maybe R8.
     

Share This Page