SECURITY NOTICE: Please read the security notice in the site help forum immediately.

Sega megadrive genesis video issue

Discussion in 'Repair, Restoration, Conservation and Preservation' started by Chisharpe, Dec 27, 2016.

  1. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
  2. rama

    rama Robust Member

    Joined:
    Dec 17, 2015
    Messages:
    280
    Likes Received:
    55
    Looks like IC or trace damage. The repair won't be easy.
     
  3. GoodTofuFriday

    GoodTofuFriday Site Supporter 2015

    Joined:
    Sep 2, 2013
    Messages:
    419
    Likes Received:
    105
    Pictures of the motherboard? What power supply are you using? Where was it stored/
     
  4. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
  5. skyway1985

    skyway1985 Enthusiastic Member

    Joined:
    Jan 23, 2014
    Messages:
    507
    Likes Received:
    116
    You need to recap the board completely, caps are dry. Ibought a Japanese VA3 that was EXACTLY like this, capacitors were the issue, if i left it on long enough and turned it off and on it would clean up the graphics, but not until i completely replaced all the caps did it fix the issue 100%.
     
    Chisharpe likes this.
  6. GoodTofuFriday

    GoodTofuFriday Site Supporter 2015

    Joined:
    Sep 2, 2013
    Messages:
    419
    Likes Received:
    105
    Looks like something may have spilled where the metal heatsink is. this where the 7805 regulators are. Your model is a va5/6 which had two of them.
    do you have a mulitmeter
     
  7. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    Yes I do have a meter
     
  8. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    I've replaced caps before but never done something this big
     
  9. GoodTofuFriday

    GoodTofuFriday Site Supporter 2015

    Joined:
    Sep 2, 2013
    Messages:
    419
    Likes Received:
    105
    [​IMG]

    plug in and turn on the genesis. Measure the voltage on the OUT pin. on both regulators it should be around 5v. Black wire from the meter goes to GND. red one goes to OUT
     
  10. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    Thanks I'll do it and get back to you
     
  11. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    They both measured 4.96 exactly
     
  12. skyway1985

    skyway1985 Enthusiastic Member

    Joined:
    Jan 23, 2014
    Messages:
    507
    Likes Received:
    116
    they should be measuring more like 5.03, anything under 5 is usually not good. not saying that's the main problem though.
     
  13. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    Could that be them on my power supply failing
     
  14. skyway1985

    skyway1985 Enthusiastic Member

    Joined:
    Jan 23, 2014
    Messages:
    507
    Likes Received:
    116
    yes this could be the problem, best way to check is get another adapter and retest voltage output.
     
  15. GoodTofuFriday

    GoodTofuFriday Site Supporter 2015

    Joined:
    Sep 2, 2013
    Messages:
    419
    Likes Received:
    105
    4.96v should be good enough. it wouldnt cause the extreme glitching you see. From here I would agree that it needs a recap. While it looks intimidating, its more tedious.
     
    skyway1985 likes this.
  16. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    Where would be best for me to get the caps from in the U.K.?
     
  17. skyway1985

    skyway1985 Enthusiastic Member

    Joined:
    Jan 23, 2014
    Messages:
    507
    Likes Received:
    116
    Talk To Bad_Ad84, he will be able to help with reliable sources in the UK.
     
  18. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    Really appreciate your help guys. Just wanna bring it back to life as I have far more sentimental value than anything else
     
  19. Chisharpe

    Chisharpe Member

    Joined:
    Dec 27, 2016
    Messages:
    18
    Likes Received:
    11
    How long did you used to have to leave it on for the graphics to improve?
     
  20. skyway1985

    skyway1985 Enthusiastic Member

    Joined:
    Jan 23, 2014
    Messages:
    507
    Likes Received:
    116
    i would have to repeatedly shut it on and off and then leave it on for up to 1/2hr before the graphics would straighten out.
     

Share This Page